1996 GT foglights not working - Muscular Mustangs
User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 14 Old 02-19-2008, 09:51 PM Thread Starter
Senior Member
 
Join Date: Oct 2006
Location: Dighton, Massachusetts
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
1996 GT foglights not working

Does anyone know which fuse is for the foglights? I don't have an owner's manual and it doesn't say on the fusepanel.

Bright Regetta Blue 1988 Mustang GT 5.0

White 1996 Mustang GT
*Flowmaster 40 series catback
Mike23386 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 02-19-2008, 10:33 PM
Banned
 
Join Date: May 2004
Location: NEPA
Posts: 2,112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)





quick5pnt0 is offline  
post #3 of 14 Old 02-19-2008, 10:40 PM Thread Starter
Senior Member
 
Join Date: Oct 2006
Location: Dighton, Massachusetts
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well unfortunately everything else works that's on the same fuse as the foglights. I guess I need new bulbs.

Bright Regetta Blue 1988 Mustang GT 5.0

White 1996 Mustang GT
*Flowmaster 40 series catback
Mike23386 is offline  
 
post #4 of 14 Old 02-20-2008, 08:34 AM
Banned
 
Join Date: May 2004
Location: NEPA
Posts: 2,112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Mike23386
Well unfortunately everything else works that's on the same fuse as the foglights. I guess I need new bulbs.
Do you have a test light or volt meter? You might want to check to see if there is power to the plug (that goes to the bulb) just to rule out other problems.



quick5pnt0 is offline  
post #5 of 14 Old 02-20-2008, 10:01 AM Thread Starter
Senior Member
 
Join Date: Oct 2006
Location: Dighton, Massachusetts
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'll have to test that today. I thought there was supposed to be an amber indicator light on the foglight switch? Is there supposed to be a light in the ashtray door? There seems to be a random bulb underneath the console just sneaking out the passenger side enough to light the floor. I felt the console and it is really hot in that area and I don't want a fire.

Bright Regetta Blue 1988 Mustang GT 5.0

White 1996 Mustang GT
*Flowmaster 40 series catback
Mike23386 is offline  
post #6 of 14 Old 02-20-2008, 10:51 AM
Banned
 
Join Date: May 2004
Location: NEPA
Posts: 2,112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thats probably the light for the ash tray, maybe it fell out of its holder if thats possible. I don't believe my car has a light on the foglight switch.



quick5pnt0 is offline  
post #7 of 14 Old 02-20-2008, 07:14 PM Thread Starter
Senior Member
 
Join Date: Oct 2006
Location: Dighton, Massachusetts
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well, apparently someone took the console out because that random bulb was for the ashtray, the cigarette lighter was unplugged, and the foglight switch was unplugged. Everything is fixed now

Bright Regetta Blue 1988 Mustang GT 5.0

White 1996 Mustang GT
*Flowmaster 40 series catback
Mike23386 is offline  
post #8 of 14 Old 02-21-2008, 07:44 AM
Banned
 
Join Date: May 2004
Location: NEPA
Posts: 2,112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
LOL, awesome! I love when things turn out simple like that.



quick5pnt0 is offline  
post #9 of 14 Old 02-21-2008, 10:19 AM Thread Starter
Senior Member
 
Join Date: Oct 2006
Location: Dighton, Massachusetts
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
LOL. But the question is..... Is there a reason why they were left unplugged or was it just an accident? And I notice at night when I have just my regular driving lights on and the heat on high it pops the heater fuse. If the lights are off with heat on high everything is fine or if the lights are on with the heat on the 3rd setting just before high everything is fine. I replaced it twice with the same 15amp that was in it, but this last time I put a 25amp in. I see on that diagram you sent, it calls for a 30a. It has been fine with the 25amp but I'll put a 30amp in when I get to the store.

Bright Regetta Blue 1988 Mustang GT 5.0

White 1996 Mustang GT
*Flowmaster 40 series catback
Mike23386 is offline  
post #10 of 14 Old 02-21-2008, 11:10 AM
Banned
 
Join Date: May 2004
Location: NEPA
Posts: 2,112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
LOL, yea you never know. Maybe thats the problem, a fuse that only has half the amp rating.

I'd stick a paper clip in it and be done. (obviously i'm joking)



quick5pnt0 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Muscular Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome