93 - 5.0 Engine Miss/Flutter - Muscular Mustangs
User Tag List

 
LinkBack Thread Tools
post #1 of 2 Old 05-03-2009, 01:51 PM Thread Starter
 
Join Date: May 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
93 - 5.0 Engine Miss/Flutter

I have a 1993 5.0 Automatic GT that has a miss/flutter when I drive up a grade with the engine under a load especially at low speeds (40-50mph). (I notice it especially in the overdrive setting on the transmission).

I have about 90,000 miles and did a tuneup about 10K miles ago (new plugs/wires, rotor, dist cap, etc.)

It is not a regular miss, but an intermittent miss.

Would a bad or dirty EGR valve cause this problem?

I just had the tranismission rebuilt recently (due to a total failure of the transmission) but the problem remains.

Any other ideas as to what may be causing the annoying engine flutter?
Thanks
Poppy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-03-2009, 06:03 PM
Banned
 
Join Date: May 2004
Location: NEPA
Posts: 2,112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: 93 - 5.0 Engine Miss/Flutter

Unfortunately with something like this it could be many many different things. First thing I'd suggest is scanning the computer for codes. Hopefully it'll come up with a fault code which will point you in the right direction.



quick5pnt0 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Muscular Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome