93 5.0LX Studdering at 1000-2000 RPM, RPM Flux, stalling etc - Page 2 - Muscular Mustangs
User Tag List

Reply
 
LinkBack Thread Tools
post #11 of 15 Old 03-21-2008, 06:35 PM
Banned
 
Join Date: May 2004
Location: NEPA
Posts: 2,112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That sucks! sorry to hear that.



quick5pnt0 is offline  
Sponsored Links
Advertisement
 
post #12 of 15 Old 03-31-2008, 03:22 PM Thread Starter
 
Join Date: Mar 2008
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well brought her to the shop, they pulled a code for the MAF. And he let me take it so I didn't get hit with his charge for the install. Just changed it about ten minutes ago, haven't run her yet still at work. But something I did find really pissy was the price of used mustang parts as compared to used say Sable or Taurus parts. As some of you may now the MAF on the 5.0 is the same as the MAF on the 3.8, of course I didn't know that till today. I didn't want to blow $100 on a new one if it wasn't the fix so I hit the junk yard. They gave me the 3.8 one and yes it's the same as the 5.0 I double checked. The search I did on ebay lead me to a used MAF for god dang 63-70 plus shipping. I did a search for a Taurus and a buy it now for 10, Un-F'ng believable. Man I hope this works. I've got a deal on a beautiful Jeep Wrangler that I can make if this is the fix.
93ramvert is offline  
post #13 of 15 Old 04-13-2008, 01:32 PM Thread Starter
 
Join Date: Mar 2008
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
UPDATE!!!!!!!!!!!!!!!

So, for any of you flowing this mess, I decided after all the changes I would check the fuel injectors. Found the problem. Two out of the 8 had completely lost the plastic tips basically heat cracking and material loss. Two others had started heat cracks in the tips, and the black crap I mentioned earlier on in the post was in some of the filter screens of others.

Now I'm going to replace all 8, but my question is has anyone ever had any issues with the Ford Motorsports Cobra upper and lower intakes. They are replica versions made in china (F'ng chinese), prob. made of lead. Anyway I'm wondering if the poor manufacture of the intake may be playing a role in this whole thing. I may have to look into purchasing another intake.
Attached Images
File Type: jpg injectors.jpg (9.1 KB, 2018 views)
93ramvert is offline  
 
post #14 of 15 Old 04-13-2008, 02:12 PM
Banned
 
Join Date: May 2004
Location: NEPA
Posts: 2,112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I've never heard anything bad about the cobra knock offs. I know that they aren't made to the same standards as the real cobra intakes (flashing not ground off, different finish, etc) but never anything bad.



quick5pnt0 is offline  
post #15 of 15 Old 04-14-2008, 07:35 AM Thread Starter
 
Join Date: Mar 2008
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by quick5pnt0
I've never heard anything bad about the cobra knock offs. I know that they aren't made to the same standards as the real cobra intakes (flashing not ground off, different finish, etc) but never anything bad.
Well thats good to know. I didn't know any better when I bought it and it's what I got. Oh well live and learn. While I'm waiting for the injectors I'm going to grind down the upper intake.
93ramvert is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Muscular Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome