Muscular Mustangs - Reply to Topic
Thread: engine hesitation problem... Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Muscular Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-26-2005 12:27 PM
thanks for the help guys...I am gonna remove my cats see if it helps. If not at least it will sound better lol. I didnt know the computer would still put out a code if the check engine light wasnt on guess you learn something new everyday thanks. If you guys can think of anything else please let me know. thanks again
05-25-2005 07:59 PM
quick5pnt0 It is possible the cats are bad, but with this sort of problem it's really hard to diagnose because it could be so many different things.
I had a somewhat similar problem on my 94 Cobra when i bought it. The car seemed to rev up fine but when i would get going it would just fall flat on its face after like 3000rpms. Turns out i had a spare ignition coil laying around and swapped them and that turned out to be the problem.

You should probably start with checking to see if your computer outputs any codes. Remember the engine light doesnt need to be on for there to be codes in the system, and it could help lead you in the right direction.



05-25-2005 07:48 PM
It sounds like theres a possiblity that one of your cats are clogged/collapsed. I could be totally off, but i'm just putting two and two together. What i mean is if one of your cats were clogged it would only make sense you would be smelling exhaust fumes (the gas you smell) because the exhaust backpressure would be raised making your headers leak.
Of course i could be totally off.
05-25-2005 05:50 PM
engine hesitation problem...

hey guys...I have a hesitation and skipping problem with my 93GT. when i am not moving the car revs fine and has no problems but as soon as i start driving the car hesitates and skips.(gets worse when i get on it) The car also runs hot. I can also smell gas inside the car when i open the windows. I changed my spark plugs, cap and roter, spark plug wires, cleaned my mas air sensor, checked my map sensor, checked the egr valve and its still there. The I even tried uninstalling my 6al msd thinking that may have gone bad and still nothing. I have a full bassani muffler system as well including high flow cats. I was thinking it could be my cats or oxygen senors. Just wanted to get another opinion before i go and remove my cats. Any sugestions? thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome